rules 953 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. #!/usr/bin/make -f
  2. CFLAGS = -Wall -g
  3. ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
  4. CFLAGS += -O0
  5. else
  6. CFLAGS += -O2
  7. endif
  8. configure: configure-stamp
  9. configure-stamp:
  10. dh_testdir
  11. touch configure-stamp
  12. build: build-stamp
  13. build-stamp: configure-stamp
  14. dh_testdir
  15. $(MAKE) CONFIG=Release
  16. touch $@
  17. clean:
  18. dh_testdir
  19. dh_testroot
  20. rm -f build-stamp configure-stamp
  21. $(MAKE) CONFIG=Release clean
  22. dh_clean
  23. install: build
  24. dh_testdir
  25. dh_testroot
  26. dh_clean -k
  27. dh_installdirs
  28. cp $(CURDIR)/bin/premake $(CURDIR)/debian/premake/usr/bin
  29. binary-indep: build install
  30. binary-arch: build install
  31. dh_testdir
  32. dh_testroot
  33. dh_installchangelogs $(CURDIR)/CHANGES.txt
  34. dh_installdocs
  35. dh_installman $(CURDIR)/debian/premake.1
  36. dh_link
  37. dh_strip
  38. dh_compress
  39. dh_fixperms
  40. dh_installdeb
  41. dh_shlibdeps
  42. dh_gencontrol
  43. dh_md5sums
  44. dh_builddeb
  45. binary: binary-indep binary-arch
  46. .PHONY: build clean binary-indep binary-arch binary install configure