12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061 |
- #!/usr/bin/make -f
- CFLAGS = -Wall -g
- ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
- else
- CFLAGS += -O2
- endif
- configure: configure-stamp
- configure-stamp:
- dh_testdir
- touch configure-stamp
- build: build-stamp
- build-stamp: configure-stamp
- dh_testdir
- $(MAKE) CONFIG=Release
- touch $@
- clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
- $(MAKE) CONFIG=Release clean
- dh_clean
- install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- cp $(CURDIR)/bin/premake $(CURDIR)/debian/premake/usr/bin
- binary-indep: build install
- binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs $(CURDIR)/CHANGES.txt
- dh_installdocs
- dh_installman $(CURDIR)/debian/premake.1
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary install configure
|